re = /^((?:729)?\d+(?:[a-zA-Z])*\.(?:jpg|png))/m
str = '12345#jpg
7290000232.png
0000232.jpg
232.png
000005234abcdef.jpg
abcede23123.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end