#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.+\.)??(.*v10.+|.*watson.|.*vortex.|1drv|llnw|.*win.+|.ms.+|.*a.microsoft.+)\.(com|net)$"
Local $sString = "http-e-darwin.hulustream.com" & @CRLF & _
"api.weather.msn.com" & @CRLF & _
"arc.msn.com" & @CRLF & _
"g.ceipmsn.com" & @CRLF & _
"storecatalogrevocation.storequality.microsoft.com" & @CRLF & _
"sls.update.microsoft.com" & @CRLF & _
"tsfe.trafficshaping.dsp.mp.microsoft.com" & @CRLF & _
"-------------------------------------" & @CRLF & _
"activity.windows.com" & @CRLF & _
"array603-prod.do.dsp.mp.microsoft.com" & @CRLF & _
"client.wns.windows.com" & @CRLF & _
"ctldl.windowsupdate.com" & @CRLF & _
"evoke-windowsservices-tas.msedge.net" & @CRLF & _
"settings-win.data.microsoft.com" & @CRLF & _
"v10.events.data.microsoft.com" & @CRLF & _
"vortex.data.microsoft.com" & @CRLF & _
"watson.telemetry.microsoft.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")