$re = '/^(.+\.)??(.*v10.+|.*watson.|.*vortex.|1drv|llnw|.*win.+|.ms.+|.*a.microsoft.+)\.(com|net)$/m';
$str = 'http-e-darwin.hulustream.com
api.weather.msn.com
arc.msn.com
g.ceipmsn.com
storecatalogrevocation.storequality.microsoft.com
sls.update.microsoft.com
tsfe.trafficshaping.dsp.mp.microsoft.com
-------------------------------------
activity.windows.com
array603-prod.do.dsp.mp.microsoft.com
client.wns.windows.com
ctldl.windowsupdate.com
evoke-windowsservices-tas.msedge.net
settings-win.data.microsoft.com
v10.events.data.microsoft.com
vortex.data.microsoft.com
watson.telemetry.microsoft.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);