import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+\\.)??(.*v10.+|.*watson.|.*vortex.|1drv|llnw|.*win.+|.ms.+|.*a.microsoft.+)\\.(com|net)$";
final String string = "http-e-darwin.hulustream.com\n"
+ "api.weather.msn.com\n"
+ "arc.msn.com\n"
+ "g.ceipmsn.com\n"
+ "storecatalogrevocation.storequality.microsoft.com\n"
+ "sls.update.microsoft.com\n"
+ "tsfe.trafficshaping.dsp.mp.microsoft.com\n"
+ "-------------------------------------\n"
+ "activity.windows.com\n"
+ "array603-prod.do.dsp.mp.microsoft.com\n"
+ "client.wns.windows.com\n"
+ "ctldl.windowsupdate.com\n"
+ "evoke-windowsservices-tas.msedge.net\n"
+ "settings-win.data.microsoft.com\n"
+ "v10.events.data.microsoft.com\n"
+ "vortex.data.microsoft.com\n"
+ "watson.telemetry.microsoft.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}