const regex = /^(.+\.)??(.*v10.+|.*watson.|.*vortex.|1drv|llnw|.*win.+|.ms.+|.*a.microsoft.+)\.(com|net)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.+\\.)??(.*v10.+|.*watson.|.*vortex.|1drv|llnw|.*win.+|.ms.+|.*a.microsoft.+)\\.(com|net)$', 'gm')
const str = `http-e-darwin.hulustream.com
api.weather.msn.com
arc.msn.com
g.ceipmsn.com
storecatalogrevocation.storequality.microsoft.com
sls.update.microsoft.com
tsfe.trafficshaping.dsp.mp.microsoft.com
-------------------------------------
activity.windows.com
array603-prod.do.dsp.mp.microsoft.com
client.wns.windows.com
ctldl.windowsupdate.com
evoke-windowsservices-tas.msedge.net
settings-win.data.microsoft.com
v10.events.data.microsoft.com
vortex.data.microsoft.com
watson.telemetry.microsoft.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}