// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.+\.)??(.*v10.+|.*watson.|.*vortex.|1drv|llnw|.*win.+|.ms.+|.*a.microsoft.+)\.(com|net)$").unwrap();
let string = "http-e-darwin.hulustream.com
api.weather.msn.com
arc.msn.com
g.ceipmsn.com
storecatalogrevocation.storequality.microsoft.com
sls.update.microsoft.com
tsfe.trafficshaping.dsp.mp.microsoft.com
-------------------------------------
activity.windows.com
array603-prod.do.dsp.mp.microsoft.com
client.wns.windows.com
ctldl.windowsupdate.com
evoke-windowsservices-tas.msedge.net
settings-win.data.microsoft.com
v10.events.data.microsoft.com
vortex.data.microsoft.com
watson.telemetry.microsoft.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}