import Foundation
let pattern = #"^(.+\.)??(.*v10.+|.*watson.|.*vortex.|1drv|llnw|.*win.+|.ms.+|.*a.microsoft.+)\.(com|net)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http-e-darwin.hulustream.com
api.weather.msn.com
arc.msn.com
g.ceipmsn.com
storecatalogrevocation.storequality.microsoft.com
sls.update.microsoft.com
tsfe.trafficshaping.dsp.mp.microsoft.com
-------------------------------------
activity.windows.com
array603-prod.do.dsp.mp.microsoft.com
client.wns.windows.com
ctldl.windowsupdate.com
evoke-windowsservices-tas.msedge.net
settings-win.data.microsoft.com
v10.events.data.microsoft.com
vortex.data.microsoft.com
watson.telemetry.microsoft.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)