import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{8}[A-Z]|\\d{1,8})$";
final String string = "# Correctos (incluyendo parciales)\n"
+ "1\n"
+ "12\n"
+ "123\n"
+ "1234\n"
+ "12345\n"
+ "123456\n"
+ "1234567\n"
+ "12345678\n"
+ "12345678Z\n\n"
+ "# Incorrectos\n"
+ "1Z\n"
+ "123456789\n"
+ "1/\n"
+ "/\n"
+ "@#~\n"
+ "12345678AZ\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}