use strict;
my $str = '# Correctos (incluyendo parciales)
1
12
123
1234
12345
123456
1234567
12345678
12345678Z
# Incorrectos
1Z
123456789
1/
/
@#~
12345678AZ
';
my $regex = qr/^(?:\d{8}[A-Z]|\d{1,8})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}