const regex = /^(?:\d{8}[A-Z]|\d{1,8})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{8}[A-Z]|\\d{1,8})$', 'gm')
const str = `# Correctos (incluyendo parciales)
1
12
123
1234
12345
123456
1234567
12345678
12345678Z
# Incorrectos
1Z
123456789
1/
/
@#~
12345678AZ
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}