re = /^(?:\d{8}[A-Z]|\d{1,8})$/m
str = '# Correctos (incluyendo parciales)
1
12
123
1234
12345
123456
1234567
12345678
12345678Z
# Incorrectos
1Z
123456789
1/
/
@#~
12345678AZ
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end