// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\d{8}[A-Z]|\d{1,8})$").unwrap();
let string = "# Correctos (incluyendo parciales)
1
12
123
1234
12345
123456
1234567
12345678
12345678Z
# Incorrectos
1Z
123456789
1/
/
@#~
12345678AZ
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}