#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(((?:[^()]+|(?R))+)\)"
Local $sString = "(1.00000000+cos(1.0-3.0))" & @CRLF & _
"(1.000000000+cos(1.0-3.0))" & @CRLF & _
"cos(1.5574077246549023+0.9092974268256817+tan(3)+sin(4)+tan(5))"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")