use strict;
my $str = '(1.00000000+cos(1.0-3.0))
(1.000000000+cos(1.0-3.0))
cos(1.5574077246549023+0.9092974268256817+tan(3)+sin(4)+tan(5))';
my $regex = qr/\(((?:[^()]+|(?R))+)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}