using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(((?:[^()]+|(?R))+)\)";
string input = @"(1.00000000+cos(1.0-3.0))
(1.000000000+cos(1.0-3.0))
cos(1.5574077246549023+0.9092974268256817+tan(3)+sin(4)+tan(5))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}