$re = '/\(((?:[^()]+|(?R))+)\)/m';
$str = '(1.00000000+cos(1.0-3.0))
(1.000000000+cos(1.0-3.0))
cos(1.5574077246549023+0.9092974268256817+tan(3)+sin(4)+tan(5))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);