const regex = /\(((?:[^()]+|(?R))+)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(((?:[^()]+|(?R))+)\\)', 'gm')
const str = `(1.00000000+cos(1.0-3.0))
(1.000000000+cos(1.0-3.0))
cos(1.5574077246549023+0.9092974268256817+tan(3)+sin(4)+tan(5))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}