// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\(((?:[^()]+|(?R))+)\)").unwrap();
let string = "(1.00000000+cos(1.0-3.0))
(1.000000000+cos(1.0-3.0))
cos(1.5574077246549023+0.9092974268256817+tan(3)+sin(4)+tan(5))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}