#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"(url|title|tags)":("([^""]+)"|\[[^[]+])"
Local $sString = ""url":"http://www.netcharles.com/orwell/essays.htm"," & @CRLF & _
""domain":"netcharles.com"," & @CRLF & _
""title":"Orwell Essays & Journalism Section - Charles' George Orwell Links"," & @CRLF & _
""tags":["orwell","writing","literature","journalism","essays","politics","essay","reference","language","toread"]," & @CRLF & _
"" & @CRLF & _
""index":2931," & @CRLF & _
""time_created":1345419323," & @CRLF & _
""num_saves":24"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")