import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(url|title|tags)\":(\"([^\"\"]+)\"|\\[[^[]+])";
final String string = "\"url\":\"http://www.netcharles.com/orwell/essays.htm\",\n"
+ "\"domain\":\"netcharles.com\",\n"
+ "\"title\":\"Orwell Essays & Journalism Section - Charles' George Orwell Links\",\n"
+ "\"tags\":[\"orwell\",\"writing\",\"literature\",\"journalism\",\"essays\",\"politics\",\"essay\",\"reference\",\"language\",\"toread\"],\n\n"
+ "\"index\":2931,\n"
+ "\"time_created\":1345419323,\n"
+ "\"num_saves\":24";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}