// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"(url|title|tags)":("([^""]+)"|\[[^[]+])"#).unwrap();
let string = "\"url\":\"http://www.netcharles.com/orwell/essays.htm\",
\"domain\":\"netcharles.com\",
\"title\":\"Orwell Essays & Journalism Section - Charles' George Orwell Links\",
\"tags\":[\"orwell\",\"writing\",\"literature\",\"journalism\",\"essays\",\"politics\",\"essay\",\"reference\",\"language\",\"toread\"],
\"index\":2931,
\"time_created\":1345419323,
\"num_saves\":24";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}