import re
regex = re.compile(r"\"(url|title|tags)\":(\"([^\"\"]+)\"|\[[^[]+])", flags=re.MULTILINE)
test_str = ("\"url\":\"http://www.netcharles.com/orwell/essays.htm\",\n"
"\"domain\":\"netcharles.com\",\n"
"\"title\":\"Orwell Essays & Journalism Section - Charles' George Orwell Links\",\n"
"\"tags\":[\"orwell\",\"writing\",\"literature\",\"journalism\",\"essays\",\"politics\",\"essay\",\"reference\",\"language\",\"toread\"],\n\n"
"\"index\":2931,\n"
"\"time_created\":1345419323,\n"
"\"num_saves\":24")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")