using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(url|title|tags)"":(""([^""]+)""|\[[^[]+])";
string input = @"""url"":""http://www.netcharles.com/orwell/essays.htm"",
""domain"":""netcharles.com"",
""title"":""Orwell Essays & Journalism Section - Charles' George Orwell Links"",
""tags"":[""orwell"",""writing"",""literature"",""journalism"",""essays"",""politics"",""essay"",""reference"",""language"",""toread""],
""index"":2931,
""time_created"":1345419323,
""num_saves"":24";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}