#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([a-z]+[A-Z]+\w*)"
Local $sString = "(e.g. wOrd instead of word; leSS instead of less)." & @CRLF & _
"" & @CRLF & _
"UPperCaSe" & @CRLF & _
"" & @CRLF & _
"USA"
Local $sSubst = "\L\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)