re = /([a-z]+[A-Z]+\w*)/m
str = '(e.g. wOrd instead of word; leSS instead of less).
UPperCaSe
USA'
subst = '\\L\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result