package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z]+[A-Z]+\w*)`)
var str = `(e.g. wOrd instead of word; leSS instead of less).
UPperCaSe
USA`
var substitution = "\L\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}