use strict;
my $str = '(e.g. wOrd instead of word; leSS instead of less).
UPperCaSe
USA';
my $regex = qr/([a-z]+[A-Z]+\w*)/mp;
my $subst = '\\L\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";