import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z\\u00C0-\\u00D6\\u00D8-\\u00DD][a-z\\u00E0-\\u00F6\\u00F8-\\u00FF]*(?:-[A-Z\\u00C0-\\u00D6\\u00D8-\\u00DD][a-z\\u00E0-\\u00F6\\u00F8-\\u00FF]*)?$";
final String string = "Jean-Luc\n"
+ "J-L\n"
+ "J-Yes\n"
+ "Jean-Yves\n"
+ "Jean\n"
+ "Jyloup-P\n"
+ "Aurore D.\n"
+ "Jean-louis\n"
+ "jean-pierre\n"
+ "Özil\n"
+ "Ôrore-Àko\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}