$re = '/^[A-Z\u00C0-\u00D6\u00D8-\u00DD][a-z\u00E0-\u00F6\u00F8-\u00FF]*(?:-[A-Z\u00C0-\u00D6\u00D8-\u00DD][a-z\u00E0-\u00F6\u00F8-\u00FF]*)?$/m';
$str = 'Jean-Luc
J-L
J-Yes
Jean-Yves
Jean
Jyloup-P
Aurore D.
Jean-louis
jean-pierre
Özil
Ôrore-Àko
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);