// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z\u00C0-\u00D6\u00D8-\u00DD][a-z\u00E0-\u00F6\u00F8-\u00FF]*(?:-[A-Z\u00C0-\u00D6\u00D8-\u00DD][a-z\u00E0-\u00F6\u00F8-\u00FF]*)?$").unwrap();
let string = "Jean-Luc
J-L
J-Yes
Jean-Yves
Jean
Jyloup-P
Aurore D.
Jean-louis
jean-pierre
Özil
Ôrore-Àko
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}