import re
regex = re.compile(r"^[A-Z\u00C0-\u00D6\u00D8-\u00DD][a-z\u00E0-\u00F6\u00F8-\u00FF]*(?:-[A-Z\u00C0-\u00D6\u00D8-\u00DD][a-z\u00E0-\u00F6\u00F8-\u00FF]*)?$", flags=re.MULTILINE)
test_str = ("Jean-Luc\n"
"J-L\n"
"J-Yes\n"
"Jean-Yves\n"
"Jean\n"
"Jyloup-P\n"
"Aurore D.\n"
"Jean-louis\n"
"jean-pierre\n"
"Özil\n"
"Ôrore-Àko\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")