const regex = /^[A-Z\u00C0-\u00D6\u00D8-\u00DD][a-z\u00E0-\u00F6\u00F8-\u00FF]*(?:-[A-Z\u00C0-\u00D6\u00D8-\u00DD][a-z\u00E0-\u00F6\u00F8-\u00FF]*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z\\u00C0-\\u00D6\\u00D8-\\u00DD][a-z\\u00E0-\\u00F6\\u00F8-\\u00FF]*(?:-[A-Z\\u00C0-\\u00D6\\u00D8-\\u00DD][a-z\\u00E0-\\u00F6\\u00F8-\\u00FF]*)?$', 'gm')
const str = `Jean-Luc
J-L
J-Yes
Jean-Yves
Jean
Jyloup-P
Aurore D.
Jean-louis
jean-pierre
Özil
Ôrore-Àko
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}