#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z_][a-zA-Z0-9_]*$"
Local $sString = "2_pi" & @CRLF & _
"x_2" & @CRLF & _
"x___3" & @CRLF & _
"x 2" & @CRLF & _
"positionRobot" & @CRLF & _
"piece_presente" & @CRLF & _
"_commande_vanne" & @CRLF & _
"-courant_sortie" & @CRLF & _
"_alarme_" & @CRLF & _
"panne#2" & @CRLF & _
"int" & @CRLF & _
"défaillance" & @CRLF & _
"f'" & @CRLF & _
"INT "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")