import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z_][a-zA-Z0-9_]*$";
final String string = "2_pi\n"
+ "x_2\n"
+ "x___3\n"
+ "x 2\n"
+ "positionRobot\n"
+ "piece_presente\n"
+ "_commande_vanne\n"
+ "-courant_sortie\n"
+ "_alarme_\n"
+ "panne#2\n"
+ "int\n"
+ "défaillance\n"
+ "f'\n"
+ "INT ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}