# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[a-zA-Z_][a-zA-Z0-9_]*$"
test_str = ("2_pi\n"
"x_2\n"
"x___3\n"
"x 2\n"
"positionRobot\n"
"piece_presente\n"
"_commande_vanne\n"
"-courant_sortie\n"
"_alarme_\n"
"panne#2\n"
"int\n"
"défaillance\n"
"f'\n"
"INT ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.