re = /^[a-zA-Z_][a-zA-Z0-9_]*$/m
str = '2_pi
x_2
x___3
x 2
positionRobot
piece_presente
_commande_vanne
-courant_sortie
_alarme_
panne#2
int
défaillance
f\'
INT '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end