package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z_][a-zA-Z0-9_]*$`)
var str = `2_pi
x_2
x___3
x 2
positionRobot
piece_presente
_commande_vanne
-courant_sortie
_alarme_
panne#2
int
défaillance
f'
INT `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}