#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:(.+\n.+){3})(\n))"
Local $sString = "test1;" & @CRLF & _
"test2;" & @CRLF & _
"test3;" & @CRLF & _
"test4;" & @CRLF & _
"read5;" & @CRLF & _
"read6;" & @CRLF & _
"read7;" & @CRLF & _
"read8;" & @CRLF & _
"read9;" & @CRLF & _
"read10;"
Local $sSubst = "$1\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)