const regex = /((?:(.+\n.+){3})(\n))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:(.+\\n.+){3})(\\n))', 'gm')
const str = `test1;
test2;
test3;
test4;
read5;
read6;
read7;
read8;
read9;
read10;`;
const subst = `$1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);