import Foundation
let pattern = #"((?:(.+\n.+){3})(\n))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test1;
test2;
test3;
test4;
read5;
read6;
read7;
read8;
read9;
read10;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)