re = /((?:(.+\n.+){3})(\n))/m
str = 'test1;
test2;
test3;
test4;
read5;
read6;
read7;
read8;
read9;
read10;'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result