import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:(.+\\n.+){3})(\\n))";
final String string = "test1;\n"
+ "test2;\n"
+ "test3;\n"
+ "test4;\n"
+ "read5;\n"
+ "read6;\n"
+ "read7;\n"
+ "read8;\n"
+ "read9;\n"
+ "read10;";
final String subst = "$1\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}