$re = '/((?:(.+\n.+){3})(\n))/m';
$str = 'test1;
test2;
test3;
test4;
read5;
read6;
read7;
read8;
read9;
read10;';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;