#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b(*SKIP)(*FAIL)|([\d\w.]+)"
Local $sString = "0.123456789" & @CRLF & _
"0.12345678" & @CRLF & _
"100" & @CRLF & _
"100.123" & @CRLF & _
"5.12457" & @CRLF & _
"5" & @CRLF & _
"5.1" & @CRLF & _
"abc" & @CRLF & _
"00.12345678" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")