use strict;
my $str = '0.123456789
0.12345678
100
100.123
5.12457
5
5.1
abc
00.12345678
';
my $regex = qr/\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b(*SKIP)(*FAIL)|([\d\w.]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}