using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b(*SKIP)(*FAIL)|([\d\w.]+)";
string input = @"0.123456789
0.12345678
100
100.123
5.12457
5
5.1
abc
00.12345678
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}