re = /\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b(*SKIP)(*FAIL)|([\d\w.]+)/m
str = '0.123456789
0.12345678
100
100.123
5.12457
5
5.1
abc
00.12345678
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end