import re
regex = re.compile(r"\b(0\.\d{1,8}|\d+(?!.)|(?!0)\d+\.\d{1,8})\b(*SKIP)(*FAIL)|([\d\w.]+)", flags=re.MULTILINE)
test_str = ("0.123456789\n"
"0.12345678\n"
"100\n"
"100.123\n"
"5.12457\n"
"5\n"
"5.1\n"
"abc\n"
"00.12345678\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")