import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(0\\.\\d{1,8}|\\d+(?!.)|(?!0)\\d+\\.\\d{1,8})\\b(*SKIP)(*FAIL)|([\\d\\w.]+)";
final String string = "0.123456789\n"
+ "0.12345678\n"
+ "100\n"
+ "100.123\n"
+ "5.12457\n"
+ "5\n"
+ "5.1\n"
+ "abc\n"
+ "00.12345678\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}