$re = '/<p>(\s*)(<a(.*)>)?(\s*)(https?:\/\/)?(w{3}\.)?(instagram\.com)\/(p\/)?(?<photoID>[A-Za-z0-9-_]{11})(\S*)(\s*)(<\/a>)?(\s*)?<\/p>/';
$str = 'Best case
<p>https://www.instagram.com/p/B9XK4J3jVui/</p>
Whitespace
<p>
https://www.instagram.com/p/B9XK4J3jVui/
</p>
Protocol variations
<p>http://www.instagram.com/p/B9XK4J3jVui/</p>
<p>www.instagram.com/p/B9XK4J3jVui/</p>
<p>instagram.com/p/B9XK4J3jVui/</p>
Trailing slash or not
<p>http://www.instagram.com/p/B9XK4J3jVui/</p>
<p>http://www.instagram.com/p/B9XK4J3jVui</p>
Linked
<p><a href="http://www.instagram.com/p/B9XK4J3jVui/">http://www.instagram.com/p/B9XK4J3jVui/</a></p>
<p>
<a href="http://www.instagram.com/p/B9XK4J3jVui/">
http://www.instagram.com/p/B9XK4J3jVui/
</a>
</p>
Extraneous URL params
<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar</p>
<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar&baz=buzz</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);